動作環境

MTCMSの動作には以下の環境が必要となります。

種別 詳細
対応Movable Type Movable Type 5.0x
※Movable Type 4には対応しておりません ※Movable Type 5.1対応は9月リリース予定のMTCMS 5.3で対応を予定しております ※Movable Type Open Sourceでは動作しません
対応OS
  • Windows Server 2003 / 2008
  • RedHat Enterprise Linux 4/5
  • Solaris 10
  • Cent OS 5
  • Mac OS 10.5以上
対応ミドルウェア
  • Apache 1.x以上 または Microsoft IIS バージョン7.5以上
  • Perlバージョン5.8.1以上
    • Movable Typeが動作するために必要なCPANモジュールのインストール
    • ImageMagick
    • Mail::Sendmail
    • Archive::Zip(サイトのZipアップロード)
    • Net::SSLeay、Net::POP3、IO::Stringy(メール投稿)
    • Mail::POP3Client、IO::Socket::SSL(SSLメール投稿)
    • Web::Scraper(WebsiteImporter)
    • HTML::LinkExtor(リンク切れチェック)
  • PHPバージョン5.x以上
データベース
クライアント
  • 必要なファイルをWEBサーバーにアップロードするためのFTPもしくはシェル環境
  • JavaScriptとCookieが利用可能なウェブ・ブラウザ(以下は推奨環境)
    • Microsoft Internet Explorerバージョン6以上
    • Mozilla Firefoxバージョン3以上

制限事項

  • ステージングサーバーオプションはWindows環境では利用できません。またRsync・SSH鍵認証が必要です。
  • ケータイキットを動作させるためにはPHPの動作が必要です。
  • アクセス制限・Perl動的生成を快適に動作させるためにはFastCGIが必要です。
  • アクセス制限はフィーチャーフォンでは動作いたしません。