動作環境

MTCMSパッケージ版の動作には以下の環境が必要となります。

種別 環境
Movable Type Movable Type 6.x
※Movable Type 5.0では動作しません。
OS

すべてのエディション

  • Cent OS 5.x以上

MTCMS EnterpriseはWindows環境に対応します。

  • RedHat Enterprise 5.x以上
  • Windows Server 2008
  • MacOS 10.5以上
ミドルウェア
mtcms cloud enterprise

すべてのエディション

  • Apache 2.x以上
  • Perlバージョン5.8.8以上
    • Movable Typeが動作するために必要なCPANモジュールのインストール
    • ImageMagick
    • Mail::Sendmail
    • Archive::Zip(サイトのZipアップロード)
    • Net::SSLeay、Net::POP3、IO::Stringy(メール投稿)
    • Mail::POP3Client、IO::Socket::SSL(SSLメール投稿)
    • Web::Scraper(WebsiteImporter)
    • HTML::Parser (メール投稿 )
    • HTML::Entities (メール投稿、多言語機能 、RSS投稿)
    • XML::Parser (RSS投稿)
  • PHPバージョン5.x以上
    • php-mbstrings
    • php-gd またはコマンドライン版ImageMagick

MTCMS Enterpriseは以下の環境に対応します。

  • Microsoft IIS バージョン7.5以上
データベース

すべてのエディション

  • MySQLバージョン5.0.x

MTCMS Enterpriseは以下の環境に対応します。

  • Microsoft SQL Server 2008
  • Oracle 11g
クライアント
  • 必要なファイルをWEBサーバーにアップロードするためのFTPもしくはシェル環境
  • JavaScriptとCookieが利用可能なウェブ・ブラウザ(以下は推奨環境)
    • Microsoft Internet Explorerバージョン 8
    • Mozilla Firefoxバージョン3以上

制限事項

  • 複数人数で同時に更新を行う用途の場合、快適に動作させるためにはPSGIサーバもしくはFastCGIが必要になります。
  • ページ数・利用人数が大規模になる場合、性能がサーバースペックに依存します。
  • ケータイキットを動作させるためにはPHPの動作が必要です。
  • アクセス制限・Perl動的生成を快適に動作させるためにはPSGIサーバもしくはFastCGIが必要です。
  • アクセス制限はフィーチャーフォンでは動作いたしません。
  • MTCMS StandardMTCMS Standard
  • MTCMS EnterpriseMTCMS Enterprise

各項目にアイコンがついている場合は、そのエディション限定の機能となります。アイコンが無い場合は全エディション共通です。エディションについて詳しく